Abril 22, 2018, 01:56:10 pm

Autor Tema: Problema con sendmail.  (Leído 5109 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado francisco_snake

  • Me das tu IP?
  • *
  • Mensajes: 3
    • Ver Perfil
Problema con sendmail.
« en: Febrero 17, 2015, 11:25:05 am »
Hola, resulta que tengo un servidor web con un formulario php para recibir emails, siempre ha funcionado perfectamente con sendmail instalado y sin tocar el php.ini, pero de repente dejó de funcionar y no se que ha pasado, ¿ Alguien me puede orientar ?, el servidor está bajo debian 7, apache y php5.

Gracias de antemano.

Desconectado locvtvs

  • evil genius
  • Colaborador
  • ****
  • Mensajes: 2341
  • wir waren namenlos... wir haben einen namen
    • Ver Perfil
    • |_ocutus
Re:Problema con sendmail.
« Respuesta #1 en: Febrero 17, 2015, 06:33:15 pm »
tenes acceso a los logs? sin eso es como adivinar...


saludos
You are not allowed to view links. Register or Login

Desconectado francisco_snake

  • Me das tu IP?
  • *
  • Mensajes: 3
    • Ver Perfil
Re:Problema con sendmail.
« Respuesta #2 en: Febrero 18, 2015, 04:13:14 am »
Si tengo acceso, en /var/log/mail.log cada vez que envio un mail desde el formulario se me añade al log estas dos lineas:

Feb 18 11:19:14 server sm-mta[26690]: gethostbyaddr(192.168.1.3) failed: 1
Feb 18 11:19:14 server sm-mta[26692]: starting daemon (8.14.4): SMTP+queueing@00:10:00

Saludos.

Desconectado francisco_snake

  • Me das tu IP?
  • *
  • Mensajes: 3
    • Ver Perfil
Re:Problema con sendmail.
« Respuesta #3 en: Febrero 18, 2015, 11:17:35 am »
Al final he cambiado sendmail por ssmtp pero sigue sin funcionar, he comprobado y con "ssmtp You are not allowed to view links. Register or Login" puedo enviar un correo desde la terminal pero desde el enviar.php no funciona, el código es este:

Código: You are not allowed to view links. Register or Login
<?php
 $headers 
"MIME-Version: 1.0\r\n";
$headers .= "Content-type: text/html; charset=iso-8859-1\r\n"

$mi_email="francisco.dominguez.lerma@gmail.com";
$Asunto="mensaje desde formulario Comunidad GNU";
 
$Nombre $_POST["nombre"];
$CorreoElectronico $_POST["correo"];
$Mensaje $_POST["mensaje"];


$Contenido=$Nombre." con la direcction de correo: ".$CorreoElectronico." ha enviado el siguiente Mail:\n\n";
$Contenido.=$Mensaje;
mail($mi_email$Asunto$Contenido$headers) or die("<h4>Problemas enviando mail</h4>");
echo 
"<h4>Mensaje enviado con exito</h4>";
?>

Saludos.

Desconectado locvtvs

  • evil genius
  • Colaborador
  • ****
  • Mensajes: 2341
  • wir waren namenlos... wir haben einen namen
    • Ver Perfil
    • |_ocutus
Re:Problema con sendmail.
« Respuesta #4 en: Febrero 23, 2015, 06:20:25 pm »
si podes enviar desde la terminal no es problema del server sino del formulario. pregunta en desarrollo web.


saludos

Desconectado pacosn1111

  • Me das tu IP?
  • *
  • Mensajes: 154
  • Sexo: Masculino
    • Ver Perfil
    • Aprende python volando
Re:Problema con sendmail.
« Respuesta #5 en: Febrero 25, 2015, 08:45:09 am »
Al final era problema del fichero de configuración de ssmtp, lo reconfiguré y ya funciona todo perfectamente, gracias por vuestras respuestas.

Por si a alguien más le sirve, el archivo de configuracion a crear para enviar a gmail correos con ssmtp es el de este enlace:

You are not allowed to view links. Register or Login

Saludos.
¿Quieres aprender python desde cero?

Entra en:

You are not allowed to view links. Register or Login


xx
[RESUELTO] Uso de sendmail

Iniciado por TXS

3 Respuestas
1148 Vistas
Último mensaje Enero 24, 2014, 04:24:52 am
por TXS
resuelto
Problema con Decrypt rot1.(( Problema resuelto))

Iniciado por Anllelop

6 Respuestas
2045 Vistas
Último mensaje Diciembre 28, 2011, 10:27:55 am
por 2Fac3R
question
problema de pc lenta problema de caja de dvd

Iniciado por comcom.com

0 Respuestas
894 Vistas
Último mensaje Enero 10, 2014, 05:15:31 pm
por comcom.com
xx
[PROBLEMA]tengo un problema de conexion

Iniciado por ferky

2 Respuestas
1242 Vistas
Último mensaje ſeptiembre 06, 2009, 11:31:33 am
por MUSUL
question
problema con wpe

Iniciado por Whitemystery

1 Respuestas
2279 Vistas
Último mensaje Enero 29, 2015, 10:20:59 pm
por midnight
xx
PROBLEMA PC :S

Iniciado por fede0692

6 Respuestas
1186 Vistas
Último mensaje ſeptiembre 17, 2009, 01:28:12 pm
por fede0692
question
Problema con Spy-Net 2.6

Iniciado por starmanmod

22 Respuestas
5052 Vistas
Último mensaje Abril 11, 2011, 01:39:02 pm
por MAX1MU5
xx
problema con el IP

Iniciado por ledzeppelin

4 Respuestas
1403 Vistas
Último mensaje Noviembre 10, 2006, 09:09:08 am
por mandiubi
xx
Un problema please

Iniciado por anarkostr0

9 Respuestas
1731 Vistas
Último mensaje Junio 05, 2007, 11:59:27 am
por _fran_
xx
Problema CPU

Iniciado por jamp

1 Respuestas
1033 Vistas
Último mensaje Agosto 21, 2009, 12:33:39 am
por danny17_18